about summary refs log tree commit diff
path: root/third_party/gerrit-queue/default.nix
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2021-12-14T16·23+0100
committerclbot <clbot@tvl.fyi>2021-12-14T17·14+0000
commitb3c4057f4bcb770785ba7147e40aa98e38171d08 (patch)
tree180fb293e2bb925bce3753f6c36cbb1f3d21d8f0 /third_party/gerrit-queue/default.nix
parentb68f7eebb9763c0ea8f135f72026bfb787b78c6c (diff)
refactor(3p/gerrit-queue): use go:embed, bump go1.16, drop shell.nix r/3243
Previously, gerrit-queue used statik to embed files. Since go1.16, we
have go:embed, which solves this much nicer, without any requirements to
have the statik binary around.

As the only other thing the shell.nix and .envrc plumbing did was bring
a version of Go in scope, it's dropped now. We assume to have a
recent-enough go binary around, else go will complain.

Imported from https://github.com/flokli/gerrit-queue/pull/9

Change-Id: I851b06777a29d4f2d955cf3a7db6455a7189bc46
Reviewed-on: https://cl.tvl.fyi/c/depot/+/4329
Tested-by: BuildkiteCI
Reviewed-by: tazjin <mail@tazj.in>
Autosubmit: tazjin <mail@tazj.in>
Diffstat (limited to 'third_party/gerrit-queue/default.nix')
-rw-r--r--third_party/gerrit-queue/default.nix8
1 files changed, 1 insertions, 7 deletions
diff --git a/third_party/gerrit-queue/default.nix b/third_party/gerrit-queue/default.nix
index 468d5b9b54..427e312183 100644
--- a/third_party/gerrit-queue/default.nix
+++ b/third_party/gerrit-queue/default.nix
@@ -3,15 +3,9 @@
 pkgs.buildGoModule {
   pname = "gerrit-queue";
   version = "master";
-  vendorSha256 = "1bqllafvd4yy4cy6barpqhycxmhzcx3p5shpzhd8qwxwwg0clxs6";
+  vendorSha256 = "0n5h7j416yb2mwic9c3rhqza64jlvl7iw507r9mkw3jadn4whm7a";
   src = ./.;
 
-  # gerrit-queue embeds static assets which need to be generated
-  nativeBuildInputs = [ pkgs.statik ];
-  preBuild = ''
-    statik -f
-  '';
-
   meta = with lib; {
     description = "Gerrit submit bot";
     homepage = "https://github.com/tweag/gerrit-queue";