about summary refs log tree commit diff
path: root/third_party/emacs/carp-mode.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-12-15T22·59+0000
committerGitHub <noreply@github.com>2019-12-15T22·59+0000
commite8b184adcc56e2ce6c0cbb86d45344e4f1ac98af (patch)
tree8f9573801796c6524ad253bed9a19401b6b336e7 /third_party/emacs/carp-mode.nix
parent00c9060c2f0ec581db8841aa34fd92c0e9953693 (diff)
parent458163910b4ab08c885e076e5f3b9ecf1b3521af (diff)
merge(PR#11): Move bits of Emacs configuration into local packages r/156
As requested by @wpcarro, some bits of my Emacs configuration are now in separate local packages (located at `//depot/tools/emacs-pkgs/`).

Specifically this change introduces:

* `tools.emacs-pkgs.dottime`: A package to render time in the modeline as [dottime](https://dotti.me)
* `tools.emacs-pkgs.term-switcher`: A package to quickly switch between and open new terminal instances in EXWM using ivy

My Emacs configuration is updated to accomodate these refactorings.
Diffstat (limited to 'third_party/emacs/carp-mode.nix')
-rw-r--r--third_party/emacs/carp-mode.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/third_party/emacs/carp-mode.nix b/third_party/emacs/carp-mode.nix
new file mode 100644
index 000000000000..869cf05c19a8
--- /dev/null
+++ b/third_party/emacs/carp-mode.nix
@@ -0,0 +1,23 @@
+{ pkgs, ... }:
+
+with pkgs.third_party;
+with emacsPackagesNg;
+
+melpaBuild rec {
+  pname = "carp-mode";
+  version = "3.0";
+  packageRequires = [ clojure-mode ];
+
+  recipe = builtins.toFile "recipe" ''
+    (carp-mode :fetcher github
+        :repo "carp-lang/carp"
+        :files ("emacs/*.el"))
+  '';
+
+  src = fetchFromGitHub {
+    owner = "carp-lang";
+    repo = "carp";
+    rev = "6954642cadee730885717201c3180c7acfb1bfa9";
+    sha256 = "1pz4x2qkwjbz789bwc6nkacrjpzlxawxhl2nv0xdp731y7q7xyk9";
+  };
+}