about summary refs log tree commit diff
path: root/third_party/dhall/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-04-10T12·00+0200
committertazjin <mail@tazj.in>2021-04-10T14·32+0000
commit6489d94ad60c431d27836a0bc65953e44175b262 (patch)
tree720f7e08ccff5ed7f14f4a058a5d890fc081dda4 /third_party/dhall/default.nix
parent9c5b5600ea3e8916af5715185ef57e57f36cf82b (diff)
refactor(3p/dhall): Move easy-dhall-nix import into separate folder r/2465
This is part of paving the way for clearly distinguishing between
packages from nixpkgs and //third_party.

See also: b/108, cl/2910

Change-Id: I28b5abd1f0f9fa3c4478c9f255b2025f4a4139f1
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2917
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: Profpatsch <mail@profpatsch.de>
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'third_party/dhall/default.nix')
-rw-r--r--third_party/dhall/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/third_party/dhall/default.nix b/third_party/dhall/default.nix
new file mode 100644
index 0000000000..6f3782233f
--- /dev/null
+++ b/third_party/dhall/default.nix
@@ -0,0 +1,22 @@
+{ pkgs, ... }:
+
+let
+  # binary releases of dhall tools, since the build in nixpkgs is
+  # broken most of the time. The binaries are also fully static
+  # builds, instead of the half-static crap that nixpkgs produces.
+  easy-dhall-nix =
+    import (builtins.fetchTarball {
+      url = "https://github.com/justinwoo/easy-dhall-nix/archive/eae7f64c4d6c70681e5a56c84198236930ba425e.tar.gz";
+      sha256 = "1y2x15v8a679vlpxazjpibfwajp6zph60f8wjcm4xflbvazk0dx7";
+    }) { inherit pkgs; };
+in {
+  dhall = easy-dhall-nix.dhall-simple;
+  dhall-bash = easy-dhall-nix.dhall-bash-simple;
+  dhall-docs = easy-dhall-nix.dhall-docs-simple;
+  dhall-json = easy-dhall-nix.dhall-json-simple;
+  dhall-lsp-server = easy-dhall-nix.dhall-lsp-simple;
+  dhall-nix = easy-dhall-nix.dhall-nix-simple;
+  # not yet in dhall-simple
+  # dhall-nixpkgs = easy-dhall-nix.dhall-nixpkgs-simple;
+  dhall-yaml = easy-dhall-nix.dhall-yaml-simple;
+}