about summary refs log tree commit diff
path: root/third_party/default.nix
diff options
context:
space:
mode:
authorGriffin Smith <grfn@gws.fyi>2020-06-29T01·27-0400
committerglittershark <grfn@gws.fyi>2020-06-29T01·56+0000
commit8091da8f0f6efd365dddf4a09555ed49c093ea50 (patch)
tree0c79b385807ba80de21a9fd2f09ec5cbb57067bc /third_party/default.nix
parent0ecc9b4ed3e53698dc44332abd06c67a6f8ffdbb (diff)
feat(3p/haskellPackages): port in patches from xanthous r/1124
Add a few relatively uncontroversial patches to fix some broken packages
that I had developed for xanthous to the top-level third_party tree, so
they can be reused by other people in the monorepo

Change-Id: I68740477bda278c5dcc123080029ee4bd2cae37a
Reviewed-on: https://cl.tvl.fyi/c/depot/+/740
Reviewed-by: Profpatsch <mail@profpatsch.de>
Reviewed-by: tazjin <mail@tazj.in>
Diffstat (limited to 'third_party/default.nix')
-rw-r--r--third_party/default.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/third_party/default.nix b/third_party/default.nix
index 02df1365c0..8f6bdc907b 100644
--- a/third_party/default.nix
+++ b/third_party/default.nix
@@ -77,7 +77,6 @@ let
       graphviz
       gzip
       haskell
-      haskellPackages
       iana-etc
       imagemagickBig
       installShellFiles
@@ -172,6 +171,10 @@ let
       perl
       perlPackages
       utillinuxMinimal;
+
+    haskellPackages = (nixpkgs.haskellPackages.override {
+      overrides = (import ./haskell_overlay { pkgs = nixpkgs; });
+    });
   };
 
 in exposed.lib.fix(self: exposed // {