about summary refs log tree commit diff
path: root/third_party/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-05-22T19·46+0100
committerVincent Ambo <tazjin@google.com>2020-05-22T19·50+0100
commit56261f1c0813744b1a07f4a5a7e7a995a7e9fbcf (patch)
tree318e57f25e3a803c1529537a31517c86f1ebb43f /third_party/default.nix
parentc25281820f886891ec68192ff3eacf18d200ae40 (diff)
fix(ops/nixos): Pin systems to stable channel r/814
NixOS unstable has some software I want when building things, but it's
also broken.

This pins systems to the stable channel for now.
Diffstat (limited to 'third_party/default.nix')
-rw-r--r--third_party/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/third_party/default.nix b/third_party/default.nix
index 8f019b3281..aca3430c9d 100644
--- a/third_party/default.nix
+++ b/third_party/default.nix
@@ -19,8 +19,8 @@ let
   # Tracking nixos-20.03 as of 2020-05-22
   stableCommit = "48723f48ab92381f0afd50143f38e45cf3080405";
   stableNixpkgsSrc = fetchTarball {
-    url = "https://github.com/NixOS/nixpkgs-channels/archive/${commit}.tar.gz";
-    sha256 = "0nkk492aa7pr0d30vv1aw192wc16wpa1j02925pldc09s9m9i0r3";
+    url = "https://github.com/NixOS/nixpkgs-channels/archive/${stableCommit}.tar.gz";
+    sha256 = "0h3b3l867j3ybdgimfn76lw7w6yjhszd5x02pq5827l659ihcf53";
   };
   stableNixpkgs = import stableNixpkgsSrc {};
 
@@ -167,5 +167,5 @@ in exposed // {
   };
 
   # Make NixOS available
-  nixos = import "${nixpkgsSrc}/nixos";
+  nixos = import "${stableNixpkgsSrc}/nixos";
 }