about summary refs log tree commit diff
path: root/third_party/default.nix
diff options
context:
space:
mode:
authorVincent Ambo <mail@tazj.in>2021-01-29T17·14+0200
committertazjin <mail@tazj.in>2021-01-30T08·20+0000
commit8f57ca92bddf8c6a003ee91e737dffad288b8b90 (patch)
tree1dba8853797aa879308cc5c826904e2186e4a6ff /third_party/default.nix
parentc726c6c2647aab533281471e222aa64fe36e490b (diff)
chore(3p|nix): Remove typed Go r/2159
Nobody has actually done any experimentation with typed Go, so we're
getting rid of it for now - it's causing annoying IFD during build
graph generation.

Change-Id: Ibac3dea98ebed1b3ee08acda184d24c500cf695d
Reviewed-on: https://cl.tvl.fyi/c/depot/+/2458
Tested-by: BuildkiteCI
Reviewed-by: sterni <sternenseemann@systemli.org>
Reviewed-by: lukegb <lukegb@tvl.fyi>
Reviewed-by: Profpatsch <mail@profpatsch.de>
Diffstat (limited to 'third_party/default.nix')
-rw-r--r--third_party/default.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/third_party/default.nix b/third_party/default.nix
index 5c99b55d15..096396d3b6 100644
--- a/third_party/default.nix
+++ b/third_party/default.nix
@@ -67,36 +67,6 @@ in exposed.lib.fix(self: exposed // {
   emacs27-nox = assert ((exposed.lib.versions.major nixpkgs.emacs.version) == "27");
     nixpkgs.emacs-nox;
 
-  # The Go authors have released a version of Go (in alpha) that has a
-  # type system. This makes it available, specifically for use with
-  # //nix/buildTypedGo.
-  go = nixpkgs.go.overrideAttrs(old: {
-    version = "dev-go2go";
-    doCheck = false;
-    patches = []; # they all don't apply and are mostly about Darwin crap
-
-    src = nixpkgs.fetchgit {
-      url = "https://go.googlesource.com/go";
-      # You might think these hashes are trivial to update. It's just
-      # a branch in a git repository, right?
-      #
-      # Well, think again. Somehow I managed to get no fewer than 3
-      # (!) different commit hashes for the same branch by cloning
-      # this repository thrice. Only the third one (which you, the
-      # reader, can find below for your reading pleasure) actually
-      # gave me `go tool go2go`.
-      rev = "ad307489d41133f32c779cfa1b0db4a852ace047";
-      leaveDotGit = true;
-      sha256 = "1nxmqdlyfx7w3g5vhjfq24yrc9hwpsa2mjv58xrmhh8vvy50ziqq";
-
-      postFetch = ''
-        cd $out
-        ${nixpkgs.git}/bin/git log -n 1 "--format=format:devel +%H %cd" HEAD > VERSION
-        rm -rf .git
-      '';
-    };
-  });
-
   # Make NixOS available
   nixos = import "${nixpkgsSrc}/nixos";
 })