about summary refs log tree commit diff
path: root/third_party/cpp/googleapis/ci/test-install/pubsub/CMakeLists.txt
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2020-02-26T14·22+0000
committerVincent Ambo <tazjin@google.com>2020-02-26T14·22+0000
commit4bdb118d6e9fe02effa9199f48796dcec04a24b0 (patch)
tree5dd95a2bd05169f61c35de02584f302426537548 /third_party/cpp/googleapis/ci/test-install/pubsub/CMakeLists.txt
parent438050b3d9c0e1dcfe7e26d9446e19fff97ccf88 (diff)
parentc873fd3aa14fb0d8696588117b5f79693381ba3c (diff)
Add 'third_party/cpp/googleapis/' from commit 'c873fd3aa14fb0d8696588117b5f79693381ba3c' r/581
git-subtree-dir: third_party/cpp/googleapis
git-subtree-mainline: 438050b3d9c0e1dcfe7e26d9446e19fff97ccf88
git-subtree-split: c873fd3aa14fb0d8696588117b5f79693381ba3c
Diffstat (limited to 'third_party/cpp/googleapis/ci/test-install/pubsub/CMakeLists.txt')
-rw-r--r--third_party/cpp/googleapis/ci/test-install/pubsub/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/third_party/cpp/googleapis/ci/test-install/pubsub/CMakeLists.txt b/third_party/cpp/googleapis/ci/test-install/pubsub/CMakeLists.txt
new file mode 100644
index 0000000000..cc8d59e187
--- /dev/null
+++ b/third_party/cpp/googleapis/ci/test-install/pubsub/CMakeLists.txt
@@ -0,0 +1,28 @@
+# ~~~
+# Copyright 2019 Google LLC
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+#     http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+# ~~~
+
+cmake_minimum_required(VERSION 3.5)
+
+project(utilize-googleapis CXX C)
+
+# Configure the compiler options, we will be using C++11 features.
+set(CMAKE_CXX_STANDARD 11)
+set(CMAKE_CXX_STANDARD_REQUIRED ON)
+
+find_package(googleapis REQUIRED)
+
+add_executable(utilize-googleapis main.cc)
+target_link_libraries(utilize-googleapis googleapis-c++::pubsub_protos)