about summary refs log tree commit diff
path: root/third_party/common_lisp/quicklisp.nix
diff options
context:
space:
mode:
authorVincent Ambo <tazjin@google.com>2019-11-15T15·26+0000
committerVincent Ambo <tazjin@google.com>2019-11-15T15·26+0000
commitc1c379848a19a31de8febb1385c7b9e4d2a474a3 (patch)
treef019521edfb4590b6c59d84e77c422a21671ca89 /third_party/common_lisp/quicklisp.nix
parent4d852e2ef73a0901a3426ae5ab93232b6a0a8ed2 (diff)
chore(nix): Move files around to conform to new read-tree layout
Broadly speaking, the following things are included:

* there is now a uniform `args` struct that is passed to all
  derivations, package headers have been changed appropriately
* overrides are now loaded from a separate `override` folder just
  using read-tree.nix
* third-party packages have moved into the `third_party` attribute set
Diffstat (limited to 'third_party/common_lisp/quicklisp.nix')
-rw-r--r--third_party/common_lisp/quicklisp.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/third_party/common_lisp/quicklisp.nix b/third_party/common_lisp/quicklisp.nix
deleted file mode 100644
index a0040f1d6f7e..000000000000
--- a/third_party/common_lisp/quicklisp.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-# Overlay over `pkgs.lispPackages` that adds additional packages which
-# are missing from the imported Quicklisp package set in nixpkgs.
-
-{ lib, lispPackages }:
-
-let inherit (lispPackages) buildLispPackage qlOverrides fetchurl;
-in lispPackages // lib.fix(self: {
-  "s-xml" = buildLispPackage
-    ((f: x: (x // (f x)))
-       (qlOverrides."s-xml" or (x: {}))
-       (import ./quicklisp-to-nix-output/s-xml.nix {
-         inherit fetchurl;
-       }));
-
-  "s-sysdeps" = buildLispPackage
-    ((f: x: (x // (f x)))
-       (qlOverrides."s-sysdeps" or (x: {}))
-       (import ./quicklisp-to-nix-output/s-sysdeps.nix {
-         inherit fetchurl;
-       }));
-
-  "cl-prevalence" = buildLispPackage
-    ((f: x: (x // (f x)))
-       (qlOverrides."cl-prevalence" or (x: {}))
-       (import ./quicklisp-to-nix-output/cl-prevalence.nix {
-         inherit fetchurl;
-         inherit (self) s-sysdeps s-xml;
-       }));
-})