about summary refs log tree commit diff
path: root/tests/timeout.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2017-01-19T13·17+0100
committerEelco Dolstra <edolstra@gmail.com>2017-01-19T16·06+0100
commit90ee1e3fe3b3f0cba8dd31ae161eac79ba249291 (patch)
tree0ac422456d01f287e94dd0f2e9784bab14967d0e /tests/timeout.nix
parentcc3b93c991e04aff49a44dbced53f070a06f426e (diff)
Add a test for --max-silent-time
Diffstat (limited to 'tests/timeout.nix')
-rw-r--r--tests/timeout.nix20
1 files changed, 17 insertions, 3 deletions
diff --git a/tests/timeout.nix b/tests/timeout.nix
index b41368bb38e2..1f3f23f16a98 100644
--- a/tests/timeout.nix
+++ b/tests/timeout.nix
@@ -1,6 +1,20 @@
 with import ./config.nix;
 
-mkDerivation {
-  name = "timeout";
-  builder = ./timeout.builder.sh;
+{
+
+  infiniteLoop = mkDerivation {
+    name = "timeout";
+    buildCommand = ''
+      echo "‘timeout’ builder entering an infinite loop"
+      while true ; do echo -n .; done
+    '';
+  };
+
+  silent = mkDerivation {
+    name = "silent";
+    buildCommand = ''
+      sleep 60
+    '';
+  };
+
 }