about summary refs log tree commit diff
path: root/tests/timeout.nix
diff options
context:
space:
mode:
authorWill Dietz <w@wdtz.org>2017-04-05T13·13-0500
committerWill Dietz <w@wdtz.org>2017-04-08T17·59-0500
commita0c56197fcb6d13e77ccbdd28322a540352b880c (patch)
tree78eaacb2d6e7958dd3b489afb182800552c31772 /tests/timeout.nix
parent30f89e0d6564394747e20e04d486b81aeec96752 (diff)
tests/timeout: create output so tests don't trivially pass
Timeout tests rely on failed build to determine success,
so make sure these derivations (silent in particular)
don't fail regardless of timeout behavior.
Diffstat (limited to 'tests/timeout.nix')
-rw-r--r--tests/timeout.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/timeout.nix b/tests/timeout.nix
index 540fba934f..e18d717eff 100644
--- a/tests/timeout.nix
+++ b/tests/timeout.nix
@@ -5,6 +5,7 @@ with import ./config.nix;
   infiniteLoop = mkDerivation {
     name = "timeout";
     buildCommand = ''
+      touch $out
       echo "‘timeout’ builder entering an infinite loop"
       while true ; do echo -n .; done
     '';
@@ -13,6 +14,7 @@ with import ./config.nix;
   silent = mkDerivation {
     name = "silent";
     buildCommand = ''
+      touch $out
       sleep 60
     '';
   };
@@ -20,6 +22,7 @@ with import ./config.nix;
   closeLog = mkDerivation {
     name = "silent";
     buildCommand = ''
+      touch $out
       exec > /dev/null 2>&1
       sleep 1000000000
     '';