about summary refs log tree commit diff
path: root/tests/search.nix
diff options
context:
space:
mode:
authorWill Dietz <w@wdtz.org>2018-02-25T22·33-0600
committerWill Dietz <w@wdtz.org>2018-02-25T22·40-0600
commit8282c60d742dc6725723370249a341a944575d6c (patch)
treef11fb131600454175a219677d1ce19221bd63bca /tests/search.nix
parent9432f3fb7d3614bf121399cdd83c82065efedbb2 (diff)
tests: test nix search behavior
Diffstat (limited to 'tests/search.nix')
-rw-r--r--tests/search.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/tests/search.nix b/tests/search.nix
new file mode 100644
index 0000000000..fea6e7a7a6
--- /dev/null
+++ b/tests/search.nix
@@ -0,0 +1,25 @@
+with import ./config.nix;
+
+{
+  hello = mkDerivation rec {
+    name = "hello-${version}";
+    version = "0.1";
+    buildCommand = "touch $out";
+    meta.description = "Empty file";
+  };
+  foo = mkDerivation rec {
+    name = "foo-5";
+    buildCommand = ''
+      mkdir -p $out
+      echo ${name} > $out/${name}
+    '';
+  };
+  bar = mkDerivation rec {
+    name = "bar-3";
+    buildCommand = ''
+      echo "Does not build successfully"
+      exit 1
+    '';
+    meta.description = "broken bar";
+  };
+}