about summary refs log tree commit diff
path: root/tests/parallel.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2009-03-17T17·11+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2009-03-17T17·11+0000
commit51e7e32c3bf7c2fb5045b0655c2edc1fbf347455 (patch)
tree21337c26d0106fa92b5f82854f623640b24dc34e /tests/parallel.nix
parent2d5114452d8a8f73c858f9beb6bfaafe35e7bf9a (diff)
* Refactoring: renamed *.nix.in to *.nix.
Diffstat (limited to 'tests/parallel.nix')
-rw-r--r--tests/parallel.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/parallel.nix b/tests/parallel.nix
new file mode 100644
index 0000000000..eb5dd02c01
--- /dev/null
+++ b/tests/parallel.nix
@@ -0,0 +1,17 @@
+with import ./config.nix;
+
+let
+
+  mkDrv = text: inputs: mkDerivation {
+    name = "parallel";
+    builder = ./parallel.builder.sh;
+    inherit text inputs shared;
+  };
+
+  a = mkDrv "a" [];
+  b = mkDrv "b" [a];
+  c = mkDrv "c" [a];
+  d = mkDrv "d" [a];
+  e = mkDrv "e" [b c d];
+
+in e