about summary refs log tree commit diff
path: root/tests/parallel.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2009-03-23T15·16+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2009-03-23T15·16+0000
commit7aedcf946043468c169ab9b0a131be908804789b (patch)
tree0921d12c8b39d1fb6ec65c90098433ea2068cfec /tests/parallel.nix
parent3a87163b2480eaf47d626580d20049387d942066 (diff)
* Make this test a bit more robust. It's still timing dependent
  though.

Diffstat (limited to 'tests/parallel.nix')
-rw-r--r--tests/parallel.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/parallel.nix b/tests/parallel.nix
index eb5dd02c01..23f142059f 100644
--- a/tests/parallel.nix
+++ b/tests/parallel.nix
@@ -1,3 +1,5 @@
+{sleepTime ? 3}:
+
 with import ./config.nix;
 
 let
@@ -5,7 +7,7 @@ let
   mkDrv = text: inputs: mkDerivation {
     name = "parallel";
     builder = ./parallel.builder.sh;
-    inherit text inputs shared;
+    inherit text inputs shared sleepTime;
   };
 
   a = mkDrv "a" [];