about summary refs log tree commit diff
path: root/tests/nix-copy-closure.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-04-15T13·32+0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-04-15T13·32+0200
commitfb5d76b89e8b0084fb147d79af5481e09b889386 (patch)
tree49d9c393d76b43605d1e574ba93d6dc40317edf1 /tests/nix-copy-closure.nix
parenta1917208c025e0a029cb33bbf3cf69e4d4128a39 (diff)
Fix test evaluation
Diffstat (limited to 'tests/nix-copy-closure.nix')
-rw-r--r--tests/nix-copy-closure.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/nix-copy-closure.nix b/tests/nix-copy-closure.nix
index 66c19a45d4..bfd708404d 100644
--- a/tests/nix-copy-closure.nix
+++ b/tests/nix-copy-closure.nix
@@ -4,14 +4,14 @@
 
 with import <nixpkgs/nixos/lib/testing.nix> { inherit system; };
 
-makeTest ({ pkgs, ... }: let pkgA = pkgs.aterm; pkgB = pkgs.wget; in {
+makeTest (let pkgA = pkgs.aterm; pkgB = pkgs.wget; in {
 
   nodes =
     { client =
         { config, pkgs, ... }:
         { virtualisation.writableStore = true;
           virtualisation.pathsInNixDB = [ pkgA ];
-          environment.nix = nix;
+          nix.package = nix;
         };
 
       server =
@@ -19,7 +19,7 @@ makeTest ({ pkgs, ... }: let pkgA = pkgs.aterm; pkgB = pkgs.wget; in {
         { services.openssh.enable = true;
           virtualisation.writableStore = true;
           virtualisation.pathsInNixDB = [ pkgB ];
-          environment.nix = nix;
+          nix.package = nix;
         };
     };