about summary refs log tree commit diff
path: root/tests/nix-copy-closure.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2011-11-05T21·23+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2011-11-05T21·23+0000
commita6a3f3a8c26fdd6900880c13e924e6879d6c714c (patch)
tree82aa6a1db30f1f034f816616fe3e6eb44ae60176 /tests/nix-copy-closure.nix
parentfa69ff57269dfd24ff04810c04d130e3e5d94154 (diff)
* Fix race condition in the test.
Diffstat (limited to '')
-rw-r--r--tests/nix-copy-closure.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/nix-copy-closure.nix b/tests/nix-copy-closure.nix
index 5b00a9a5c8bb..7e2cf3a08870 100644
--- a/tests/nix-copy-closure.nix
+++ b/tests/nix-copy-closure.nix
@@ -37,6 +37,7 @@ makeTest ({ pkgs, ... }: let pkgA = pkgs.aterm; pkgB = pkgs.wget; in {
       $server->succeed("mkdir -m 700 /root/.ssh");
       $server->copyFileFromHost("key.pub", "/root/.ssh/authorized_keys");
       $server->waitForJob("sshd");
+      $client->waitForJob("network-interfaces");
       $client->succeed("ssh -o StrictHostKeyChecking=no " . $server->name() . " 'echo hello world'");
 
       # Copy the closure of package A from the client to the server.