about summary refs log tree commit diff
path: root/tests/multiple-outputs.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2011-12-21T17·34+0000
committerShea Levy <shea@shealevy.com>2011-12-21T17·34+0000
commitf8e54b7874b73891e39aff11dac2a5ceabef2f02 (patch)
tree78f80984c401cb430a612e5699deb4843e384fb1 /tests/multiple-outputs.nix
parentb4cee3f816ad53f9762f38c28b51a78732b249f2 (diff)
Make the reference cycle in the cyclic outputs test indirect
Diffstat (limited to 'tests/multiple-outputs.nix')
-rw-r--r--tests/multiple-outputs.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/tests/multiple-outputs.nix b/tests/multiple-outputs.nix
index 405999ce7c..09946137d7 100644
--- a/tests/multiple-outputs.nix
+++ b/tests/multiple-outputs.nix
@@ -54,12 +54,13 @@ rec {
 
   cyclic = (mkDerivation {
     name = "cyclic-outputs";
-    outputs = [ "a" "b" ];
+    outputs = [ "a" "b" "c" ];
     builder = builtins.toFile "builder.sh"
       ''
-        mkdir $a $b
+        mkdir $a $b $c
         echo $a > $b/foo
-        echo $b > $a/bar
+        echo $b > $c/bar
+        echo $c > $a/baz
       '';
   }).a;