about summary refs log tree commit diff
path: root/tests/lang/lib.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2008-07-11T13·29+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2008-07-11T13·29+0000
commit7cd88b1dec29f33188e789d780ec2e4ebb155d20 (patch)
treec2a3934a763e6968af7fce554a5840516fa6208e /tests/lang/lib.nix
parentd567baabbd99fdb92e67295a77aef76ef970e65c (diff)
* Generalised the dependencyClosure primop to builtins.genericClosure,
  which is hopefully more useful.
* New primops: length, mul, div.

Diffstat (limited to 'tests/lang/lib.nix')
-rw-r--r--tests/lang/lib.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/tests/lang/lib.nix b/tests/lang/lib.nix
index e508f28ba53f..551b67aed350 100644
--- a/tests/lang/lib.nix
+++ b/tests/lang/lib.nix
@@ -25,4 +25,28 @@ rec {
     in !(lessThan lenFileName lenExt) &&
        substring (sub lenFileName lenExt) lenFileName fileName == ext;
 
+  # Split a list at the given position.
+  splitAt = pos: list:
+    if pos == 0 then {first = []; second = list;} else
+    if list == [] then {first = []; second = [];} else
+    let res = splitAt (sub pos 1) (tail list);
+    in {first = [(head list)] ++ res.first; second = res.second;};
+
+  # Stable merge sort.
+  sortBy = comp: list:
+    if lessThan 1 (length list)
+    then
+      let
+        split = splitAt (div (length list) 2) list;
+        first = sortBy comp split.first;
+        second = sortBy comp split.second;
+      in mergeLists comp first second
+    else list;
+
+  mergeLists = comp: list1: list2:
+    if list1 == [] then list2 else
+    if list2 == [] then list1 else
+    if comp (head list2) (head list1) then [(head list2)] ++ mergeLists comp list1 (tail list2) else
+    [(head list1)] ++ mergeLists comp (tail list1) list2;
+
 }