about summary refs log tree commit diff
path: root/tests/lang/lib.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2007-01-29T14·23+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2007-01-29T14·23+0000
commit7349bd0176b8a8ced3a017bb5d0e9ebb30570722 (patch)
tree0c550418b620ecd81d386089b59e8d0272c0c565 /tests/lang/lib.nix
parent7dedbd896ade732ab2fe88a5fe88e069cb329fa5 (diff)
New primitives:
* `sub' to subtract two numbers.
* `stringLength' to get the length of a string.
* `substring' to get a substring of a string.  These should be enough
  to allow most string operations to be expressed.

Diffstat (limited to 'tests/lang/lib.nix')
-rw-r--r--tests/lang/lib.nix14
1 files changed, 11 insertions, 3 deletions
diff --git a/tests/lang/lib.nix b/tests/lang/lib.nix
index f888453ffb..ec705299a7 100644
--- a/tests/lang/lib.nix
+++ b/tests/lang/lib.nix
@@ -1,18 +1,26 @@
+with builtins;
+
 rec {
 
   fold = op: nul: list:
     if list == []
     then nul
-    else op (builtins.head list) (fold op nul (builtins.tail list));
+    else op (head list) (fold op nul (tail list));
 
   concat =
     fold (x: y: x + y) "";
 
   flatten = x:
-    if builtins.isList x
+    if isList x
     then fold (x: y: (flatten x) ++ y) [] x
     else [x];
 
-  sum = fold (x: y: builtins.add x y) 0;
+  sum = fold (x: y: add x y) 0;
+
+  hasSuffix = ext: fileName:
+    let lenFileName = stringLength fileName;
+        lenExt = stringLength ext;
+    in !(lessThan lenFileName lenExt) &&
+       substring (sub lenFileName lenExt) lenFileName fileName == ext;
 
 }