about summary refs log tree commit diff
path: root/tests/lang/lib.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2008-07-01T10·10+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2008-07-01T10·10+0000
commitd567baabbd99fdb92e67295a77aef76ef970e65c (patch)
treed31c1737c52da705c17da78edb517bc2e56b841a /tests/lang/lib.nix
parentb3b0b2a29e2842784f80cf839f84af18b0b83e90 (diff)
* Export the nix-env derivation name parsing and version comparison
  logic through the `parseDrvName' and `compareVersions' primops.
  This will allow expressions to easily check whether some dependency
  is a specific needed version or falls in some version range.  See
  tests/lang/eval-okay-versions.nix for examples.

Diffstat (limited to '')
-rw-r--r--tests/lang/lib.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/lang/lib.nix b/tests/lang/lib.nix
index ec705299a7a9..e508f28ba53f 100644
--- a/tests/lang/lib.nix
+++ b/tests/lang/lib.nix
@@ -10,6 +10,8 @@ rec {
   concat =
     fold (x: y: x + y) "";
 
+  and = fold (x: y: x && y) true;
+
   flatten = x:
     if isList x
     then fold (x: y: (flatten x) ++ y) [] x