about summary refs log tree commit diff
path: root/tests/lang/eval-okay-with.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2010-03-23T14·51+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2010-03-23T14·51+0000
commit71be50cc25544f742db2275b4621b92c4e938400 (patch)
tree44e522edc976d78ca8cf196e9722406d4eb174a4 /tests/lang/eval-okay-with.nix
parent3bfd3a4e9511e16d8a826cb271fc95acc2fb9845 (diff)
* Doh.
Diffstat (limited to 'tests/lang/eval-okay-with.nix')
-rw-r--r--tests/lang/eval-okay-with.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/lang/eval-okay-with.nix b/tests/lang/eval-okay-with.nix
index ea4ea612de..033e8d3aba 100644
--- a/tests/lang/eval-okay-with.nix
+++ b/tests/lang/eval-okay-with.nix
@@ -7,7 +7,13 @@ let {
     b = "bar";
   };
 
+  bs = {
+    a = "bar";
+  };
+
   x = with as; a + b;
 
-  body = x;
+  y = with as; with bs; a + b;
+
+  body = x + y;
 }