about summary refs log tree commit diff
path: root/tests/lang/eval-okay-types.nix
diff options
context:
space:
mode:
authorChristian Theune <ct@flyingcircus.io>2016-01-06T09·03+0100
committerChristian Theune <ct@flyingcircus.io>2016-01-06T09·03+0100
commit5cdcaf5e8edd6679f667502eec421ac4e725d4ef (patch)
treeab550f06668023ee90c3b89d23838e60fab02952 /tests/lang/eval-okay-types.nix
parentb4bda4765af09acb86a4dd71105059491e7dcc30 (diff)
Adapt tests to show that floats work properly.
Diffstat (limited to 'tests/lang/eval-okay-types.nix')
-rw-r--r--tests/lang/eval-okay-types.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-types.nix b/tests/lang/eval-okay-types.nix
index 8cb225e247fb..a34775f5e602 100644
--- a/tests/lang/eval-okay-types.nix
+++ b/tests/lang/eval-okay-types.nix
@@ -8,6 +8,16 @@ with builtins;
   (isString [ "x" ])
   (isInt (1 + 2))
   (isInt { x = 123; })
+  (isInt (1 / 2))
+  (isInt (1 + 1))
+  (isInt (1 / 2))
+  (isInt (1 * 2))
+  (isInt (1 - 2))
+  (isFloat (1.2))
+  (isFloat (1 + 1.0))
+  (isFloat (1 / 2.0))
+  (isFloat (1 * 2.0))
+  (isFloat (1 - 2.0))
   (isBool (true && false))
   (isBool null)
   (isAttrs { x = 123; })