about summary refs log tree commit diff
path: root/tests/lang/eval-okay-types.nix
diff options
context:
space:
mode:
authorzimbatm <zimbatm@zimbatm.com>2018-01-29T12·36+0000
committerzimbatm <zimbatm@zimbatm.com>2019-03-24T10·36+0100
commit514b3c7f8345cfcbbe166981214497ed9d93ae18 (patch)
treec9b5d3dec07486f41dbb31a9a0e12c83426e346e /tests/lang/eval-okay-types.nix
parent56f1ed55791fc7e8671f10263baa7a9d15b47c4b (diff)
Add isPath primop
this is added for completeness' sake since all the other possible
`builtins.typeOf` results have a corresponding `builtins.is<Type>`
Diffstat (limited to '')
-rw-r--r--tests/lang/eval-okay-types.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-types.nix b/tests/lang/eval-okay-types.nix
index a34775f5e602..9b58be5d1dd4 100644
--- a/tests/lang/eval-okay-types.nix
+++ b/tests/lang/eval-okay-types.nix
@@ -20,6 +20,8 @@ with builtins;
   (isFloat (1 - 2.0))
   (isBool (true && false))
   (isBool null)
+  (isPath /nix/store)
+  (isPath ./.)
   (isAttrs { x = 123; })
   (isAttrs null)
   (typeOf (3 * 4))