about summary refs log tree commit diff
path: root/tests/lang/eval-okay-substring.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2007-01-29T14·23+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2007-01-29T14·23+0000
commit7349bd0176b8a8ced3a017bb5d0e9ebb30570722 (patch)
tree0c550418b620ecd81d386089b59e8d0272c0c565 /tests/lang/eval-okay-substring.nix
parent7dedbd896ade732ab2fe88a5fe88e069cb329fa5 (diff)
New primitives:
* `sub' to subtract two numbers.
* `stringLength' to get the length of a string.
* `substring' to get a substring of a string.  These should be enough
  to allow most string operations to be expressed.

Diffstat (limited to 'tests/lang/eval-okay-substring.nix')
-rw-r--r--tests/lang/eval-okay-substring.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-substring.nix b/tests/lang/eval-okay-substring.nix
new file mode 100644
index 0000000000..184d72580c
--- /dev/null
+++ b/tests/lang/eval-okay-substring.nix
@@ -0,0 +1,19 @@
+with builtins;
+
+let
+
+  s = "foobar";
+
+in
+
+substring 1 2 s
++ "x"
++ substring 0 (stringLength s) s
++ "y"
++ substring 3 100 s
++ "z"
++ substring 2 (sub (stringLength s) 3) s
++ "a"
++ substring 3 0 s
++ "b"
++ substring 3 1 s