about summary refs log tree commit diff
path: root/tests/lang/eval-okay-string.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2006-05-01T14·01+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2006-05-01T14·01+0000
commit0064599a27ec44880e4ff6fa19f453e610b5ef07 (patch)
tree50289edc19dc99d5423ce8f57b99c5b8eb5597c1 /tests/lang/eval-okay-string.nix
parent6cecad2be0f7ced82658ec2a86bcf61583487959 (diff)
* String interpolation. Expressions like
    "--with-freetype2-library=" + freetype + "/lib"

  can now be written as

    "--with-freetype2-library=${freetype}/lib"

  An arbitrary expression can be enclosed within ${...}, not just
  identifiers.

* Escaping in string literals: \n, \r, \t interpreted as in C, any
  other character following \ is interpreted as-is.
  
* Newlines are now allowed in string literals.

Diffstat (limited to 'tests/lang/eval-okay-string.nix')
-rw-r--r--tests/lang/eval-okay-string.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/tests/lang/eval-okay-string.nix b/tests/lang/eval-okay-string.nix
index b5280a0cd1fa..f2452e85745b 100644
--- a/tests/lang/eval-okay-string.nix
+++ b/tests/lang/eval-okay-string.nix
@@ -1 +1,9 @@
-"foo" + "bar" + toString (/a/b + /c/d) + (/foo/bar + "/../xyzzy/." + "/foo.txt") + ("/../foo" + /x/y)
+"foo" + "bar"
+  + toString (/a/b + /c/d)
+  + (/foo/bar + "/../xyzzy/." + "/foo.txt")
+  + ("/../foo" + /x/y)
+  + "escape: \"quote\" \n \\"
+  + "end
+of
+line"
+  + "foo${if true then "b${"a" + "r"}" else "xyzzy"}blaat"