about summary refs log tree commit diff
path: root/tests/lang/eval-okay-scope-6.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2006-05-02T11·20+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2006-05-02T11·20+0000
commitae55e79541ffbce7a051794d6d25e9e8c7b63b2d (patch)
tree2288881ce2a63dc4e56ea24681dbcbad16e823e5 /tests/lang/eval-okay-scope-6.nix
parentdca43ef795c0589d47620241823393c739b99498 (diff)
* More tests.
Diffstat (limited to 'tests/lang/eval-okay-scope-6.nix')
-rw-r--r--tests/lang/eval-okay-scope-6.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-scope-6.nix b/tests/lang/eval-okay-scope-6.nix
new file mode 100644
index 000000000000..0995d4e7e7e0
--- /dev/null
+++ b/tests/lang/eval-okay-scope-6.nix
@@ -0,0 +1,7 @@
+let {
+
+  f = {x ? y, y ? x}: x + y;
+
+  body = f {x = "c";} + f {y = "d";};
+
+}