about summary refs log tree commit diff
path: root/tests/lang/eval-okay-map.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2006-09-22T15·29+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2006-09-22T15·29+0000
commit2ab4bc44c780d2e28647f7559664675b756f38b9 (patch)
tree39ecb0e001cf6c031e15b0246559b3f8f7a06ed9 /tests/lang/eval-okay-map.nix
parentd315210612a8d5eb52654407903544b72222130b (diff)
* Builtin function `add' to add integers.
* Put common test functions in tests/lang/lib.nix.

Diffstat (limited to 'tests/lang/eval-okay-map.nix')
-rw-r--r--tests/lang/eval-okay-map.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/lang/eval-okay-map.nix b/tests/lang/eval-okay-map.nix
index 924446657aec..a76c1d811454 100644
--- a/tests/lang/eval-okay-map.nix
+++ b/tests/lang/eval-okay-map.nix
@@ -1 +1,3 @@
-map (x: x + "bar") [ "foo" "bla" "xyzzy" ]
\ No newline at end of file
+with import ./lib.nix;
+
+concat (map (x: x + "bar") [ "foo" "bla" "xyzzy" ])
\ No newline at end of file