about summary refs log tree commit diff
path: root/tests/lang/eval-okay-listToAttrs.nix
diff options
context:
space:
mode:
authorMarc Weber <marco-oweber@gmx.de>2007-08-18T22·12+0000
committerMarc Weber <marco-oweber@gmx.de>2007-08-18T22·12+0000
commit2629998e9167b2d7897a2f34a6f531affc4033db (patch)
treefae92f5a8f4f1a3e105a55b748bae4db6e6cb91b /tests/lang/eval-okay-listToAttrs.nix
parentdbc0170ed998484178780d9390ae0d4434bf93b0 (diff)
primop functions listToAttrs (+test), __isAttrs, __trace added
new configuration style proposal in lib/default-unstable.nix

Diffstat (limited to 'tests/lang/eval-okay-listToAttrs.nix')
-rw-r--r--tests/lang/eval-okay-listToAttrs.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-listToAttrs.nix b/tests/lang/eval-okay-listToAttrs.nix
new file mode 100644
index 0000000000..f5eae92ccd
--- /dev/null
+++ b/tests/lang/eval-okay-listToAttrs.nix
@@ -0,0 +1,8 @@
+# this test shows how to use listToAttrs and that evaluation is still lazy (throw isn't called)
+let 
+  asi = attr: value : { inherit attr value; };
+  list = [ ( asi "a" "A" ) ( asi "b" "B" ) ];
+  a = builtins.listToAttrs list;
+  b = builtins.listToAttrs ( list ++ list );
+  r = builtins.listToAttrs [ (asi "result" [ a b ]) ( asi "throw" (throw "this should not be thrown")) ];
+in r.result