about summary refs log tree commit diff
path: root/tests/lang/eval-okay-ind-string.nix
diff options
context:
space:
mode:
authorGuillaume Maudoux <layus.on@gmail.com>2017-04-30T23·05+0200
committerGuillaume Maudoux <layus.on@gmail.com>2017-04-30T23·15+0200
commita4744254250e170f1b858e46a8b1c7904a030a2b (patch)
tree13bf297167013f5d22d6f069fb989f55576d248c /tests/lang/eval-okay-ind-string.nix
parent2f21d522c28b1e902bd7f0b5b9e7523975102d81 (diff)
Fix lexer to support `$'` in multiline strings.
Diffstat (limited to 'tests/lang/eval-okay-ind-string.nix')
-rw-r--r--tests/lang/eval-okay-ind-string.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/tests/lang/eval-okay-ind-string.nix b/tests/lang/eval-okay-ind-string.nix
index 1556aae9f54f..1669dc0648ea 100644
--- a/tests/lang/eval-okay-ind-string.nix
+++ b/tests/lang/eval-okay-ind-string.nix
@@ -117,4 +117,12 @@ let
     bar
   '';
 
-in s1 + s2 + s3 + s4 + s5 + s6 + s7 + s8 + s9 + s10 + s11 + s12 + s13 + s14 + s15
+  # Regression test: accept $'.
+  s16 = ''
+    cut -d $'\t' -f 1
+  '';
+
+  # Accept dollars at end of strings 
+  s17 = ''ending dollar $'' + ''$'' + "\n";
+
+in s1 + s2 + s3 + s4 + s5 + s6 + s7 + s8 + s9 + s10 + s11 + s12 + s13 + s14 + s15 + s16 + s17