about summary refs log tree commit diff
path: root/tests/lang/eval-okay-hash.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-02-08T18·36+0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-02-08T18·36+0100
commit52172607cfc33867c0cdb526bef99c315e98baa2 (patch)
tree350c9b7866db892d2bd0cc0e54fb37a9e0a58217 /tests/lang/eval-okay-hash.nix
parent01a5ea9914b3933e63a88184861900615be76e12 (diff)
Rename "hash" to "hashString" and handle SHA-1
Diffstat (limited to 'tests/lang/eval-okay-hash.nix')
-rw-r--r--tests/lang/eval-okay-hash.nix9
1 files changed, 5 insertions, 4 deletions
diff --git a/tests/lang/eval-okay-hash.nix b/tests/lang/eval-okay-hash.nix
index 65cd8afeb00d..2fff17f849bb 100644
--- a/tests/lang/eval-okay-hash.nix
+++ b/tests/lang/eval-okay-hash.nix
@@ -1,6 +1,7 @@
 let
-  md5 = builtins.hash "md5";
-  sha256 = builtins.hash "sha256";
-  strings = [ "text 1" "text 2" ];
+  md5 = builtins.hashString "md5";
+  sha1 = builtins.hashString "sha1";
+  sha256 = builtins.hashString "sha256";
+  strings = [ "" "text 1" "text 2" ];
 in
-  (builtins.map md5 strings) ++ (builtins.map sha256 strings)
+  (builtins.map md5 strings) ++ (builtins.map sha1 strings) ++ (builtins.map sha256 strings)