about summary refs log tree commit diff
path: root/tests/lang/eval-okay-getattrpos.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-11-18T21·22+0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-11-18T21·22+0100
commit285df765b91588e39d6f35a32e30b84c3cb5be75 (patch)
tree8f93b3fd527f44f14eacefb6c4c9385f670e8aea /tests/lang/eval-okay-getattrpos.nix
parentfc33fd86b7727365caab44c05a90d5b52209131b (diff)
Add a primop unsafeGetAttrPos to return the position of an attribute
Diffstat (limited to 'tests/lang/eval-okay-getattrpos.nix')
-rw-r--r--tests/lang/eval-okay-getattrpos.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-getattrpos.nix b/tests/lang/eval-okay-getattrpos.nix
new file mode 100644
index 000000000000..ca6b07961547
--- /dev/null
+++ b/tests/lang/eval-okay-getattrpos.nix
@@ -0,0 +1,6 @@
+let
+  as = {
+    foo = "bar";
+  };
+  pos = builtins.unsafeGetAttrPos "foo" as;
+in { inherit (pos) column line; file = baseNameOf pos.file; }