about summary refs log tree commit diff
path: root/tests/lang/eval-okay-elem.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-02-26T18·08+0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-02-26T18·08+0100
commit5ad263c26b5b9cc0ba067050e4a09b2491c9d40c (patch)
treea9251f24871514ace96343edd0059580c379fbf4 /tests/lang/eval-okay-elem.nix
parent3d0a9ec8258fc2a6ec6a73e249aa38fbd03207d8 (diff)
Test some more primops
Diffstat (limited to 'tests/lang/eval-okay-elem.nix')
-rw-r--r--tests/lang/eval-okay-elem.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-elem.nix b/tests/lang/eval-okay-elem.nix
new file mode 100644
index 0000000000..71ea7a4ed0
--- /dev/null
+++ b/tests/lang/eval-okay-elem.nix
@@ -0,0 +1,6 @@
+with import ./lib.nix;
+
+let xs = range 10 40; in
+
+[ (builtins.elem 23 xs) (builtins.elem 42 xs) (builtins.elemAt xs 20) ]
+