about summary refs log tree commit diff
path: root/tests/lang/eval-okay-delayed-with.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-07-31T11·12+0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-07-31T11·12+0200
commit7df4ef983e96f604fa84abe4aeb54dcb00a72add (patch)
tree97f4a8570bb326e340e6876bcc3c8d08f08a80e0 /tests/lang/eval-okay-delayed-with.nix
parent0a470fc3453f56a0a242d8f467b8079fe0040ff7 (diff)
Test the delayed with a bit more
Diffstat (limited to '')
-rw-r--r--tests/lang/eval-okay-delayed-with.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/tests/lang/eval-okay-delayed-with.nix b/tests/lang/eval-okay-delayed-with.nix
index 82934d6a9d..3fb023e1cd 100644
--- a/tests/lang/eval-okay-delayed-with.nix
+++ b/tests/lang/eval-okay-delayed-with.nix
@@ -1,4 +1,5 @@
 let
+
   pkgs_ = with pkgs; {
     a = derivation {
       name = "a";
@@ -13,14 +14,16 @@ let
       system = builtins.currentSystem;
       builder = "/bin/sh";
       args = [ "-c" "touch $out" ];
+      inherit a;
     };
 
     c = b;
   };
 
-  packageOverrides = p: {
-    b = derivation (p.b.drvAttrs // { name = "b-overridden"; });
+  packageOverrides = pkgs: with pkgs; {
+    b = derivation (b.drvAttrs // { name = "${b.name}-overridden"; });
   };
 
   pkgs = pkgs_ // (packageOverrides pkgs_);
-in pkgs.a.b.name
+
+in "${pkgs.a.b.name} ${pkgs.c.name} ${pkgs.b.a.name}"