about summary refs log tree commit diff
path: root/tests/lang/eval-okay-context-introspection.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2019-01-14T16·34-0500
committerShea Levy <shea@shealevy.com>2019-01-31T13·52-0500
commitb30be6b450f872f8be6dc8afa28f4b030fa8d1d1 (patch)
tree34a70603cf1f640dd277df7963996c3de7bac6a7 /tests/lang/eval-okay-context-introspection.nix
parent1d757292d0cb78beec32fcdfe15c2944a4bc4a95 (diff)
Add builtins.appendContext.
A partner of builtins.getContext, useful for the same reasons.
Diffstat (limited to 'tests/lang/eval-okay-context-introspection.nix')
-rw-r--r--tests/lang/eval-okay-context-introspection.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/tests/lang/eval-okay-context-introspection.nix b/tests/lang/eval-okay-context-introspection.nix
index d9b2ea3549..43178bd2ee 100644
--- a/tests/lang/eval-okay-context-introspection.nix
+++ b/tests/lang/eval-okay-context-introspection.nix
@@ -18,5 +18,7 @@ let
     };
   };
 
-  legit-context = "${path}${drv.outPath}${drv.foo.outPath}${drv.drvPath}";
-in builtins.getContext legit-context == desired-context
+  legit-context = builtins.getContext "${path}${drv.outPath}${drv.foo.outPath}${drv.drvPath}";
+
+  constructed-context = builtins.getContext (builtins.appendContext "" desired-context);
+in legit-context == constructed-context