about summary refs log tree commit diff
path: root/tests/lang/eval-okay-concatmap.nix
diff options
context:
space:
mode:
authorvolth <volth@volth.com>2018-07-05T02·52+0000
committervolth <volth@volth.com>2018-07-05T02·54+0000
commit403a76a18fbbbc7b1ad4b65ed8c66c9abbbffa6f (patch)
tree491ac5ef065bc2b7f03cc3f40e0f786956e14a5f /tests/lang/eval-okay-concatmap.nix
parent3defdccf4b46fe678496e5e3430c55b827477d0d (diff)
lib.concatMap and lib.mapAttrs to be builtins
Diffstat (limited to 'tests/lang/eval-okay-concatmap.nix')
-rw-r--r--tests/lang/eval-okay-concatmap.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-concatmap.nix b/tests/lang/eval-okay-concatmap.nix
new file mode 100644
index 000000000000..97da5d37a412
--- /dev/null
+++ b/tests/lang/eval-okay-concatmap.nix
@@ -0,0 +1,5 @@
+with import ./lib.nix;
+
+[ (builtins.concatMap (x: if x / 2 * 2 == x then [] else [ x ]) (range 0 10))
+  (builtins.concatMap (x: [x] ++ ["z"]) ["a" "b"])
+]