about summary refs log tree commit diff
path: root/tests/lang/eval-okay-callable-attrs.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-10-16T02·04-0400
committerShea Levy <shea@shealevy.com>2014-11-15T21·12-0500
commit997defa16617caf5fd869924558389639d1c8caf (patch)
treeba286d246324da0066c8528639e43bd26c986cdb /tests/lang/eval-okay-callable-attrs.nix
parent8cfe939b0f222e3b27493a3c62e0b1088b12e110 (diff)
Add functors (callable attribute sets).
With this, attribute sets with a `__functor` attribute can be applied
just like normal functions. This can be used to attach arbitrary
metadata to a function without callers needing to treat it specially.
Diffstat (limited to 'tests/lang/eval-okay-callable-attrs.nix')
-rw-r--r--tests/lang/eval-okay-callable-attrs.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-callable-attrs.nix b/tests/lang/eval-okay-callable-attrs.nix
new file mode 100644
index 0000000000..310a030df0
--- /dev/null
+++ b/tests/lang/eval-okay-callable-attrs.nix
@@ -0,0 +1 @@
+({ __functor = self: x: self.foo && x; foo = false; } // { foo = true; }) true