about summary refs log tree commit diff
path: root/tests/lang/eval-okay-arithmetic.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-02-26T18·08+0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-02-26T18·08+0100
commit5ad263c26b5b9cc0ba067050e4a09b2491c9d40c (patch)
treea9251f24871514ace96343edd0059580c379fbf4 /tests/lang/eval-okay-arithmetic.nix
parent3d0a9ec8258fc2a6ec6a73e249aa38fbd03207d8 (diff)
Test some more primops
Diffstat (limited to 'tests/lang/eval-okay-arithmetic.nix')
-rw-r--r--tests/lang/eval-okay-arithmetic.nix5
1 files changed, 0 insertions, 5 deletions
diff --git a/tests/lang/eval-okay-arithmetic.nix b/tests/lang/eval-okay-arithmetic.nix
index 8f307b20ea95..bbbbc4691d75 100644
--- a/tests/lang/eval-okay-arithmetic.nix
+++ b/tests/lang/eval-okay-arithmetic.nix
@@ -2,11 +2,6 @@ with import ./lib.nix;
 
 let {
 
-  range = first: last:
-    if builtins.lessThan last first
-    then []
-    else [first] ++ range (builtins.add first 1) last;
-
   /* Supposedly tail recursive version:
 
   range_ = accum: first: last: