about summary refs log tree commit diff
path: root/tests/lang/eval-okay-arithmetic.nix
diff options
context:
space:
mode:
authorvolth <volth@volth.com>2018-05-24T12·48+0000
committervolth <volth@volth.com>2018-05-24T12·51+0000
commit88c1ea30e461092db713e58fe7521c5c43c52212 (patch)
tree3f2a948b37da0076daef31facbfc09ec3ad677a7 /tests/lang/eval-okay-arithmetic.nix
parent6cc28c0589a0072e94128976ddbf8b2fbfd9f496 (diff)
add docs and tests
Diffstat (limited to '')
-rw-r--r--tests/lang/eval-okay-arithmetic.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/lang/eval-okay-arithmetic.nix b/tests/lang/eval-okay-arithmetic.nix
index bbbbc4691d75..7e9e6a0b666e 100644
--- a/tests/lang/eval-okay-arithmetic.nix
+++ b/tests/lang/eval-okay-arithmetic.nix
@@ -26,6 +26,10 @@ let {
       (56088 / 123 / 2)
       (3 + 4 * const 5 0 - 6 / id 2)
 
+      (builtins.bitAnd 12 10) # 0b1100 & 0b1010 =  8
+      (builtins.bitOr  12 10) # 0b1100 | 0b1010 = 14
+      (builtins.bitXor 12 10) # 0b1100 ^ 0b1010 =  6
+
       (if 3 < 7 then 1 else err)
       (if 7 < 3 then err else 1)
       (if 3 < 3 then err else 1)