about summary refs log tree commit diff
path: root/tests/lang/eval-fail-scope-5.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2006-05-02T11·15+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2006-05-02T11·15+0000
commitdca43ef795c0589d47620241823393c739b99498 (patch)
tree487efb83550c014333e9cc8b136a516bfec23bf2 /tests/lang/eval-fail-scope-5.nix
parent7276e194eefc807600e1dcd10566a57e557ed1ad (diff)
* Tests for NIX-45.
Diffstat (limited to 'tests/lang/eval-fail-scope-5.nix')
-rw-r--r--tests/lang/eval-fail-scope-5.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/tests/lang/eval-fail-scope-5.nix b/tests/lang/eval-fail-scope-5.nix
new file mode 100644
index 000000000000..dc8243bc8546
--- /dev/null
+++ b/tests/lang/eval-fail-scope-5.nix
@@ -0,0 +1,10 @@
+let {
+
+  x = "a";
+  y = "b";
+
+  f = {x ? y, y ? x}: x + y;
+
+  body = f {x = "c";} + f {y = "d";};
+
+}