about summary refs log tree commit diff
path: root/tests/import-derivation.nix
diff options
context:
space:
mode:
authorBas van Dijk <v.dijk.bas@gmail.com>2019-07-30T09·22+0200
committerBas van Dijk <v.dijk.bas@gmail.com>2019-07-30T09·27+0200
commit89865144c3ba0162cd37bcbe49b3095e9bab4164 (patch)
tree1a43e2906116d5ea3bcc0a39b5cd14673c191407 /tests/import-derivation.nix
parent41a52466854ab3a7d4adedc3777c0b0585ef79fe (diff)
Allow builtins.pathExists to check the existence of /nix/store paths
This makes it consitent with builtins.readDir.
Diffstat (limited to 'tests/import-derivation.nix')
-rw-r--r--tests/import-derivation.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/import-derivation.nix b/tests/import-derivation.nix
index 91adcd288f6e..44fa9a45d7e1 100644
--- a/tests/import-derivation.nix
+++ b/tests/import-derivation.nix
@@ -10,7 +10,10 @@ let
       '';
   };
 
-  value = import bar;
+  value =
+    # Test that pathExists can check the existence of /nix/store paths
+    assert builtins.pathExists bar;
+    import bar;
 
 in