about summary refs log tree commit diff
path: root/tests/hash-check.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2006-07-19T15·49+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2006-07-19T15·49+0000
commit88e54153dce2cdba9a075d9dbc81ad81e7e73435 (patch)
tree91b34f0d26c1f773c66848cfa9d558a0b1081133 /tests/hash-check.nix
parent4f3725b167cc0080c570a814e28c6181ef5c7f52 (diff)
* Add a precise test for hashDerivatioModulo.
Diffstat (limited to 'tests/hash-check.nix')
-rw-r--r--tests/hash-check.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/tests/hash-check.nix b/tests/hash-check.nix
new file mode 100644
index 0000000000..bbe4fe2479
--- /dev/null
+++ b/tests/hash-check.nix
@@ -0,0 +1,29 @@
+let {
+
+  input1 = derivation {
+    name = "dependencies-input-1";
+    system = "i086-msdos";
+    builder = "/bar/sh";
+    args = ["-e" "-x" ./dependencies.builder1.sh];
+  };
+
+  input2 = derivation {
+    name = "dependencies-input-2";
+    system = "i086-msdos";
+    builder = "/bar/sh";
+    args = ["-e" "-x" ./dependencies.builder2.sh];
+    outputHashMode = "recursive";
+    outputHashAlgo = "md5";
+    outputHash = "ffffffffffffffffffffffffffffffff";
+  };
+
+  body = derivation {
+    name = "dependencies";
+    system = "i086-msdos";
+    builder = "/bar/sh";
+    args = ["-e" "-x" (./dependencies.builder0.sh  + "/FOOBAR/../.")];
+    input1 = input1 + "/.";
+    inherit input2;
+  };
+
+}
\ No newline at end of file