about summary refs log tree commit diff
path: root/tests/gc-runtime.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2009-03-17T17·11+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2009-03-17T17·11+0000
commit51e7e32c3bf7c2fb5045b0655c2edc1fbf347455 (patch)
tree21337c26d0106fa92b5f82854f623640b24dc34e /tests/gc-runtime.nix
parent2d5114452d8a8f73c858f9beb6bfaafe35e7bf9a (diff)
* Refactoring: renamed *.nix.in to *.nix.
Diffstat (limited to 'tests/gc-runtime.nix')
-rw-r--r--tests/gc-runtime.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/tests/gc-runtime.nix b/tests/gc-runtime.nix
new file mode 100644
index 0000000000..ee5980bdff
--- /dev/null
+++ b/tests/gc-runtime.nix
@@ -0,0 +1,17 @@
+with import ./config.nix;
+
+mkDerivation {
+  name = "gc-runtime";
+  builder =
+    # Test inline source file definitions.
+    builtins.toFile "builder.sh" ''
+      mkdir $out
+
+      cat > $out/program <<EOF
+      #! ${shell}
+      sleep 10000
+      EOF
+
+      chmod +x $out/program
+    '';
+}