about summary refs log tree commit diff
path: root/tests/filter-source.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2016-03-24T13·38+0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2016-03-24T13·45+0100
commit3b81b2645706d7f8d9c0ec228426dee8ef1fc7ac (patch)
tree38538081e9a7d0db61b401b8765290c396bfe0f0 /tests/filter-source.nix
parent374198ad6d8747c135ce8d8a8284723b0968aeef (diff)
Use shorter daemon socket path in tests
Otherwise we hit the 104 character limit.

http://hydra.nixos.org/build/33562028
Diffstat (limited to 'tests/filter-source.nix')
-rw-r--r--tests/filter-source.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/filter-source.nix b/tests/filter-source.nix
index a620f0fda5c4..9071636394af 100644
--- a/tests/filter-source.nix
+++ b/tests/filter-source.nix
@@ -8,5 +8,5 @@ mkDerivation {
       type != "symlink"
       && baseNameOf path != "foo"
       && !((import ./lang/lib.nix).hasSuffix ".bak" (baseNameOf path));
-    in builtins.filterSource filter ./test-tmp/filterin;
+    in builtins.filterSource filter ((builtins.getEnv "TEST_ROOT") + "/filterin");
 }