about summary refs log tree commit diff
path: root/tests/fetchurl.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2012-07-09T19·41-0400
committerEelco Dolstra <eelco.dolstra@logicblox.com>2012-07-09T19·41-0400
commit51f9f9924bcd0c30b45e370fc69dc43e6621ef61 (patch)
tree7eb8cbc42c502303822ba25bd3940f049c93d08d /tests/fetchurl.nix
parent035aa114037857b51968e62a1176f4086e2477ec (diff)
Add a test for the fetchurl function
Diffstat (limited to 'tests/fetchurl.nix')
-rw-r--r--tests/fetchurl.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/fetchurl.nix b/tests/fetchurl.nix
new file mode 100644
index 000000000000..2abcc039a832
--- /dev/null
+++ b/tests/fetchurl.nix
@@ -0,0 +1,6 @@
+{ filename, sha256 }:
+
+import <nix/fetchurl.nix> {
+  url = "file://${filename}";
+  inherit sha256;
+}