about summary refs log tree commit diff
path: root/tests/fetchurl.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2015-10-30T10·27+0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2015-10-30T10·27+0100
commitdae5dc7ade60aa6a9a05e41133da7faebe6bdc1b (patch)
tree73dd25edb51c70422e4cb58df6ec885d6c461557 /tests/fetchurl.nix
parent5c28943e8fd19d7eb55865d45d6dc61336aa04e9 (diff)
<nix/fetchurl.nix>: Support downloading and unpacking NARs
This removes the need to have multiple downloads in the stdenv
bootstrap process (like a separate busybox binary for Linux, or
curl/mkdir/sh/bzip2 for Darwin). Now all those files can be combined
into a single NAR.
Diffstat (limited to 'tests/fetchurl.nix')
-rw-r--r--tests/fetchurl.nix6
1 files changed, 0 insertions, 6 deletions
diff --git a/tests/fetchurl.nix b/tests/fetchurl.nix
deleted file mode 100644
index 2abcc039a832..000000000000
--- a/tests/fetchurl.nix
+++ /dev/null
@@ -1,6 +0,0 @@
-{ filename, sha256 }:
-
-import <nix/fetchurl.nix> {
-  url = "file://${filename}";
-  inherit sha256;
-}