about summary refs log tree commit diff
path: root/tests/export-graph.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2009-03-17T17·38+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2009-03-17T17·38+0000
commit93b6926054b0b339d310a3075a677a65676c7c11 (patch)
tree50de8a47acee0db3fe1a996cee669b0d5bb05a45 /tests/export-graph.nix
parent51e7e32c3bf7c2fb5045b0655c2edc1fbf347455 (diff)
* Regression test for exportBuildReferencesGraph. It currently fails.
Diffstat (limited to 'tests/export-graph.nix')
-rw-r--r--tests/export-graph.nix14
1 files changed, 10 insertions, 4 deletions
diff --git a/tests/export-graph.nix b/tests/export-graph.nix
index b7afa2a85b..d65ad8c143 100644
--- a/tests/export-graph.nix
+++ b/tests/export-graph.nix
@@ -2,21 +2,27 @@ with import ./config.nix;
 
 rec {
 
-  buildGraphBuilder = builtins.toFile "build-graph-builder"
+  printRefs =
     ''
       while read path; do
           read drv
           read nrRefs
           echo "$path has $nrRefs references"
-          echo -n "$path" >> $out
+          echo "$path" >> $out
           for ((n = 0; n < $nrRefs; n++)); do read ref; echo "ref $ref"; done
       done < refs
     '';
 
-  buildGraph = mkDerivation {
+  runtimeGraph = mkDerivation {
     name = "dependencies";
-    builder = buildGraphBuilder;
+    builder = builtins.toFile "build-graph-builder" "${printRefs}";
     exportReferencesGraph = ["refs" (import ./dependencies.nix)];
   };
 
+  buildGraph = mkDerivation {
+    name = "dependencies";
+    builder = builtins.toFile "build-graph-builder" "${printRefs}";
+    exportBuildReferencesGraph = ["refs" (import ./dependencies.nix).drvPath];
+  };
+
 }