about summary refs log tree commit diff
path: root/tests/export-graph.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-11-18T10·21+0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-11-18T10·21+0000
commit90b5e692846d9b7a951155c5ed4fc7cf72b08e31 (patch)
treea341049ade10d14c92f5bc7a031acb22fa54a366 /tests/export-graph.nix
parenta478e8a7bb8c24da0ac91b7100bd0e422035c62f (diff)
Support quoted attribute names in -A
This is requires if you have attribute names with dots in them.  So
you can now say:

  $ nix-instantiate '<nixos>' -A 'config.systemd.units."postgresql.service".text' --eval-only

Fixes #151.
Diffstat (limited to 'tests/export-graph.nix')
-rw-r--r--tests/export-graph.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/export-graph.nix b/tests/export-graph.nix
index 3a0b0368d6..fdac9583db 100644
--- a/tests/export-graph.nix
+++ b/tests/export-graph.nix
@@ -14,13 +14,13 @@ rec {
       done < refs
     '';
 
-  runtimeGraph = mkDerivation {
+  foo."bar.runtimeGraph" = mkDerivation {
     name = "dependencies";
     builder = builtins.toFile "build-graph-builder" "${printRefs}";
     exportReferencesGraph = ["refs" (import ./dependencies.nix)];
   };
 
-  buildGraph = mkDerivation {
+  foo."bar.buildGraph" = mkDerivation {
     name = "dependencies";
     builder = builtins.toFile "build-graph-builder" "${printRefs}";
     exportReferencesGraph = ["refs" (import ./dependencies.nix).drvPath];