about summary refs log tree commit diff
path: root/tests/export-graph.nix
diff options
context:
space:
mode:
authorEelco Dolstra <e.dolstra@tudelft.nl>2009-03-17T16·33+0000
committerEelco Dolstra <e.dolstra@tudelft.nl>2009-03-17T16·33+0000
commit2d5114452d8a8f73c858f9beb6bfaafe35e7bf9a (patch)
tree676ad5958bce42d91d09518cf44c61a6414ac0e2 /tests/export-graph.nix
parent33ecb4299107da91f5d61131ead37afabe496649 (diff)
* Regression test for the `exportReferencesGraph'
  derivation attribute. 

Diffstat (limited to 'tests/export-graph.nix')
-rw-r--r--tests/export-graph.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/tests/export-graph.nix b/tests/export-graph.nix
new file mode 100644
index 000000000000..3e30d2dcea7a
--- /dev/null
+++ b/tests/export-graph.nix
@@ -0,0 +1,23 @@
+with import ./config.nix;
+
+rec {
+
+  buildGraphBuilder = builtins.toFile "build-graph-builder"
+    ''
+      #cat refs
+      while read path; do
+          read drv
+          read nrRefs
+          echo "$path has $nrRefs references"
+          echo -n "$path" >> $out
+          for ((n = 0; n < $nrRefs; n++)); do read ref; echo "ref $ref"; done
+      done < refs
+    '';
+
+  buildGraph = mkDerivation {
+    name = "dependencies";
+    builder = buildGraphBuilder;
+    exportReferencesGraph = ["refs" (import ./dependencies.nix)];
+  };
+
+}