about summary refs log tree commit diff
path: root/tests/config.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-11-25T17·47+0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-11-25T17·47+0100
commit0202ce6b94f287f70a6723473c73a4c7f135dae4 (patch)
treeb87dc49e456c3e9a2cb335b94ac22542a875be32 /tests/config.nix
parent9285f0aa2b44427afef7c50f0efae8f74307a7a5 (diff)
Add support for ‘make installcheck’
Diffstat (limited to 'tests/config.nix')
-rw-r--r--tests/config.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/config.nix b/tests/config.nix
new file mode 100644
index 000000000000..6244a15fa48a
--- /dev/null
+++ b/tests/config.nix
@@ -0,0 +1,20 @@
+with import <nix/config.nix>;
+
+rec {
+  inherit shell;
+
+  path = coreutils;
+
+  system = builtins.currentSystem;
+
+  shared = builtins.getEnv "_NIX_TEST_SHARED";
+
+  mkDerivation = args:
+    derivation ({
+      inherit system;
+      builder = shell;
+      args = ["-e" args.builder];
+      PATH = path;
+    } // removeAttrs args ["builder" "meta"])
+    // { meta = args.meta or {}; };
+}