about summary refs log tree commit diff
path: root/tests/check.nix
diff options
context:
space:
mode:
authorEelco Dolstra <edolstra@gmail.com>2018-01-19T12·58+0100
committerEelco Dolstra <edolstra@gmail.com>2018-01-19T12·58+0100
commit87e3d142cce442417b52610652b9d1a4fd7a6b4f (patch)
tree556201305d55f48a6bc8cec5c40ca2f57001fc28 /tests/check.nix
parent0c95776c3efdc63c4b957823d4e51d851a64ed84 (diff)
Add a test for --check / --repeat
Diffstat (limited to 'tests/check.nix')
-rw-r--r--tests/check.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/check.nix b/tests/check.nix
new file mode 100644
index 0000000000..b330ab9c98
--- /dev/null
+++ b/tests/check.nix
@@ -0,0 +1,12 @@
+with import ./config.nix;
+
+{
+  nondeterministic = mkDerivation {
+    name = "nondeterministic";
+    buildCommand =
+      ''
+        mkdir $out
+        date +%s.%N > $out/date
+      '';
+  };
+}