about summary refs log tree commit diff
path: root/tests/check-refs.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-08-28T16·57+0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-08-28T16·57+0200
commitb72e93bca8fc045b37b1e863c423cf0e91e8c479 (patch)
treea989f3e94ef1ed8501b382099b6ba6c82730fd6d /tests/check-refs.nix
parent9eddf6f0b68e1ac69d56de3c5c0899481ad2c6cf (diff)
Add disallowedReferences / disallowedRequisites
For the "stdenv accidentally referring to bootstrap-tools", it seems
easier to specify the path that we don't want to depend on, e.g.

  disallowedRequisites = [ bootstrapTools ];
Diffstat (limited to 'tests/check-refs.nix')
-rw-r--r--tests/check-refs.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/check-refs.nix b/tests/check-refs.nix
index 63791fe16094..9d90b0920542 100644
--- a/tests/check-refs.nix
+++ b/tests/check-refs.nix
@@ -55,4 +55,16 @@ rec {
     inherit dep;
   };
 
+  test9 = makeTest 9 {
+    builder = builtins.toFile "builder.sh" "mkdir $out; ln -s $dep $out/link";
+    inherit dep;
+    disallowedReferences = [dep];
+  };
+
+  test10 = makeTest 10 {
+    builder = builtins.toFile "builder.sh" "mkdir $out; echo $test5; ln -s $dep $out/link";
+    inherit dep test5;
+    disallowedReferences = [test5];
+  };
+
 }